CVE-2026-94482: Next.js: Denial of Service in App Router using Server Actions

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

Next.js is a React framework for building full-stack web applications. From 13.0.0 until 15.5.28 and 16.4.1, crafted requests targeting App Router applications with at least one Server Action can cause excessive CPU consumption and block processing of further requests in the same process. Applications using the Pages Router and App Router applications without Server Actions are not affected. This issue is fixed in versions 15.5.28 and 16.4.1.

Description quoted from the CVE record (assigned by GitHub_M, published 2026-10-22).

Weakness: CWE-770: Allocation of Resources Without Limits or Throttling

How it can be exploited

Exploitable over the network with low attack complexity only when specific conditions are present needing no privileges and no user interaction. Impact: confidentiality none, integrity none, availability high. CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: yes. Technical impact: partial.

Public exploit evidence (Exploit Observer)

Also known as: GHSA-p3m5-59mp-jv5r

Exploit Observer has no public exploit code that names this CVE or one of its aliases.

Vulnerability databases and vendor advisories (4)

Catalogue entries, not exploit evidence.

1 more reference returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.004
low predicted chance of attack
VEDAS
0.042
little exploit evidence
On CISA KEV
Not listed
Detection rule
None yet

Who is affected

ProductAffectedNot affected
vercel next.jsversion >= 13.0.0, < 15.5.28
version >= 16.0.0, < 16.4.1
Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: npm next.

How to fix it

No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

Advisories on this CVE

References

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.