CVE-2026-82186: WPLP Cookie Consent < 4.4.2 - Admin+ SQLi via ‘offset’ Parameter
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
The WPLP Cookie Consent WordPress plugin before 4.4.2 does not properly validate a pagination parameter before using it in a SQL query, allowing users with administrator privileges to perform SQL injection attacks.
Description quoted from the CVE record (assigned by WPScan, published 2026-09-04).
Weakness: CWE-89 Improper Neutralization of Special Elements used in an SQL Command (‘SQL Injection’)
How it can be exploited
Exploitable over the network with low attack complexity needing high privileges and no user interaction. Impact: confidentiality low, integrity none, availability none. CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: partial.
Public exploit evidence (Exploit Observer)
Also known as: EUVD-2026-70909, GHSA-f3xc-8q46-qff6, WPSCAN-a0285ba3-0741-4382-a037-db0ac3fc49d2
VEDAS cluster: VEDAS:FREYJBLOSSOM
Exploit Observer links 1 piece of public exploit code or detection modules that name this CVE or one of its aliases.
Exploit code and modules (1)
Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.
- Nuclei template: https://raw.githubusercontent.com/projectdiscovery/nuclei-templates/main/http/cves/2026/CVE-2026-82186.yaml
Vulnerability databases and vendor advisories (3)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2026-70909
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-f3xc-8q46-qff6
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2026-82186
2 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.007
low predicted chance of attack - VEDAS
- 0.988
strong exploit evidence - On CISA KEV
- Not listed
- Detection rule
- None yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| Unknown WPLP Cookie Consent | from 3.0.0 before 4.4.2 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
How to fix it
Fixed versions stated in the CVE record: 4.4.2.
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Exploits and technical analysis
- https://wpscan.com/vulnerability/a0285ba3-0741-4382-a037-db0ac3fc49d2/ (exploit, vdb-entry, technical-description)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.