CVE-2026-54420: LiteSpeed cPanel Plugin UNIX Symbolic Link (Symlink) Following Vulnerability

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before 5.3.2.0) mishandles symlinks provided by a user with FTP or web shell access on a shared hosting server running CloudLinux/CageFS, as exploited in the wild in May 2026.

Description quoted from the CVE record (assigned by mitre, published 2026-06-14).

Weakness: CWE-61 UNIX Symbolic Link (Symlink) Following

How it can be exploited

Exploitable over the network with high attack complexity needing low privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: no. Technical impact: total.

On CISA KEV since
2026-06-15
US federal deadline
2026-06-18
Ransomware use
Not known

Public exploit evidence (Exploit Observer)

Also known as: EUVD-2026-36657, GHSA-3g44-c4qc-cxm8

Exploit Observer links 3 pieces of public exploit code or detection modules that name this CVE or one of its aliases.

Exploit code and modules (3)

Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.

Vulnerability databases and vendor advisories (4)

Catalogue entries, not exploit evidence.

2 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.014
some chance of attack soon
VEDAS
0.508
some exploit evidence
On CISA KEV
Yes, since 2026-06-15
Detection rule
None yet
EPSS (chance of attack)
100.1CVE-2026-54420 EPSS over time2026-082026-11-01
VEDAS (exploit evidence)
100.9CVE-2026-54420 VEDAS over time2026-082026-11-01

Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.

Who is affected

ProductAffectedNot affected
LiteSpeed Technologies cPanel Plugin (WHM and cPanel PlugIn)from 2.3 before 2.4.8Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: litespeedtech litespeed_cpanel_plugin.

How to fix it

Fixed versions stated in the CVE record: 2.4.8.

CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset’s internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Vendor guidance:

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

References

Government sources

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.