CVE-2026-5430: WSO2 Multiple Products Path Traversal Vulnerability
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
The JWT authentication mechanism accepts tokens signed with algorithms other than those explicitly configured or supported. This allows an attacker to craft a JWT with an unsupported algorithm, which is then incorrectly validated, leading to unauthorized access. Successful exploitation of this vulnerability may result in unauthorized access to the system, including the potential compromise of administrative accounts and full account takeover. The CVSS score is adjusted to 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H) in single-tenant deployments, reflecting that the impact is contained within a single security authority boundary.
Description quoted from the CVE record (assigned by WSO2, published 2026-08-06).
Weakness: CWE-347: Improper Validation of Certificate With Host Mismatch
How it can be exploited
Exploitable over the network with low attack complexity needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: yes. Technical impact: total.
- On CISA KEV since
- 2026-09-24
- US federal deadline
- 2026-09-27
- Ransomware use
- Not known
Public exploit evidence (Exploit Observer)
Also known as: BDU:2026-14811, EUVD-2026-53822, GHSA-j7vh-5w8q-4m4x
VEDAS cluster: VEDAS:GAUNTLETGRIT
Exploit Observer links 3 pieces of public exploit code or detection modules that name this CVE or one of its aliases.
Exploit code and modules (3)
Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.
- Code repository: https://github.com/abraxas/cve-2026-5430
- Code repository: https://github.com/davidvrns/cve-2026-5430-wso2
- Code repository: https://github.com/getdrive/wso2_cve-2026-5430_lab
Vulnerability databases and vendor advisories (4)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2026-53822
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-j7vh-5w8q-4m4x
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2026-5430
- Vulnerability database or vendor advisory: https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-5430
10 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.224
likely to be attacked soon - VEDAS
- 0.979
strong exploit evidence - On CISA KEV
- Yes, since 2026-09-24
- Detection rule
- None yet
Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish. The vertical line is the day CISA added it to its exploited list.
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| WSO2 WSO2 Universal Gateway | from 4.5.0 before 4.5.0.57 from 4.6.0 before 4.6.0.21 | Not stated |
| WSO2 WSO2 Traffic Manager | from 4.5.0 before 4.5.0.56 from 4.6.0 before 4.6.0.21 | Not stated |
| WSO2 WSO2 API Control Plane | from 4.5.0 before 4.5.0.58 from 4.6.0 before 4.6.0.22 | Not stated |
| WSO2 WSO2 API Manager | from 4.1.0 before 4.1.0.257 from 4.2.0 before 4.2.0.197 from 4.3.0 before 4.3.0.108 from 4.4.0 before 4.4.0.72 from 4.5.0 before 4.5.0.57 from 4.6.0 before 4.6.0.21 | Not stated |
| WSO2 WSO2 Carbon API Manager Rest API Utility (org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.util) | from 9.20.74 before 9.20.74.401 from 9.28.116 before 9.28.116.417 from 9.29.120 before 9.29.120.236 from 9.30.67 before 9.30.67.167 from 9.31.86 before 9.31.86.158 from 9.32.147 before 9.32.147.59 | 9.33.106 is not affected |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: wso2 api_control_plane, wso2 api_manager, wso2 traffic_manager, wso2 universal_gateway, wso2 wso2_api_control_plane, wso2 wso2_api_manager, wso2 wso2_traffic_manager, wso2 wso2_universal_gateway.
How to fix it
Fixed versions stated in the CVE record: 4.5.0.57, 4.6.0.21, 4.5.0.56, 4.5.0.58, 4.6.0.22, 4.1.0.257, 4.2.0.197, 4.3.0.108, 4.4.0.72, 9.20.74.401, 9.28.116.417, 9.29.120.236 and others.
CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset’s internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
Vendor guidance:
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2026-5328/ (vendor-advisory)
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
References
Vendor advisories and patches
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2026-5328/ (vendor-advisory)
Government sources
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-5430 (government-resource)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.