CVE-2026-26268: Cursor sandbox escape via Git hooks
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Cursor is a code editor built for programming with AI. Sandbox escape via writing .git configuration was possible in versions prior to 2.5. A malicious agent (ie prompt injection) could write to improperly protected .git settings, including git hooks, which may cause out-of-sandbox RCE next time they are triggered. No user interaction was required as Git executes these commands automatically. Fixed in version 2.5.
Description quoted from the CVE record (assigned by GitHub_M, published 2026-02-13).
Weakness: CWE-862: Missing Authorization
How it can be exploited
Exploitable over the network with high attack complexity needing high privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.
Public exploit evidence (Exploit Observer)
Also known as: EUVD-2026-7368
Exploit Observer has no public exploit code that names this CVE or one of its aliases.
Vulnerability databases and vendor advisories (2)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2026-7368
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2026-26268
1 more reference returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.007
low predicted chance of attack - VEDAS
- 0.054
little exploit evidence - On CISA KEV
- Not listed
- Detection rule
- None yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| cursor cursor | version < 2.5 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: anysphere cursor.
How to fix it
No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
Advisories on this CVE
- Cursor 2026 CVEs (2 Apr 2026)
References
Other references
- https://github.com/cursor/cursor/security/advisories/GHSA-8pcm-8jpx-hv8r (x_refsource_CONFIRM)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.