CVE-2026-112816: Improper certificate validation in the HTTPS listener in LXD
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
Description quoted from the CVE record (assigned by canonical, published 2026-10-30).
Weakness: CWE-295 Improper certificate validation
How it can be exploited
Exploitable over the network with low attack complexity with no special attack requirements needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: yes. Technical impact: total.
Public exploit evidence (Exploit Observer)
Exploit Observer evidence for this CVE has not been fetched yet.
Live scores
- EPSS
- 0.003
low predicted chance of attack - VEDAS
- 0.508
some exploit evidence - On CISA KEV
- Not listed
- Detection rule
- None yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| Canonical LXD (lxd) | from 4.0.14 before 4.0.15 from 5.0.10 before 5.0.11 from 5.21.8 before 5.21.9 from 6.9.0 before 6.10.1 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
How to fix it
Fixed versions stated in the CVE record: 4.0.15, 5.0.11, 5.21.9, 6.10.1.
Vendor guidance:
- https://github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4 (vendor-advisory)
- https://discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557 (vendor-advisory)
- https://discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024 (release-notes)
- https://discourse.ubuntu.com/t/lxd-5-21-9-lts-has-been-released/90565/1 (release-notes)
- https://discourse.ubuntu.com/t/lxd-5-0-11-lts-has-been-released/90570/1 (release-notes)
- https://discourse.ubuntu.com/t/lxd-4-0-15-lts-has-been-released/90571 (release-notes)
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
Advisories on this CVE
- Canonical LXD and MicroCloud CVE-2026-112816: unverified mTLS client chain lets anyone impersonate a trusted client (full advisory)
- Canonical LXD and MicroCloud: mTLS client-certificate chain not verified, any trusted client can be impersonated (CVE-2026-112816) (28 Oct 2026)
References
Vendor advisories and patches
- https://github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4 (vendor-advisory)
- https://discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557 (vendor-advisory)
- https://discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024 (release-notes)
- https://discourse.ubuntu.com/t/lxd-5-21-9-lts-has-been-released/90565/1 (release-notes)
- https://discourse.ubuntu.com/t/lxd-5-0-11-lts-has-been-released/90570/1 (release-notes)
- https://discourse.ubuntu.com/t/lxd-4-0-15-lts-has-been-released/90571 (release-notes)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS). Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.