CVE-2026-110264: Integer Overflow or Wraparound in GitLab

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.

Description quoted from the CVE record (assigned by GitLab, published 2026-10-22).

Weakness: CWE-190: Integer Overflow or Wraparound

How it can be exploited

Exploitable over the network with low attack complexity needing no privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: yes. Technical impact: total.

Public exploit evidence (Exploit Observer)

Also known as: BDU:2026-17391, GHSA-83vq-rvff-66gw

VEDAS cluster: VEDAS:FROGFALL

Exploit Observer links 9 pieces of public exploit code or detection modules that name this CVE or one of its aliases.

Exploit code and modules (9)

Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.

Research and write-ups (2)

Vulnerability databases and vendor advisories (3)

Catalogue entries, not exploit evidence.

News (1)

219 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.013
some chance of attack soon
VEDAS
0.983
strong exploit evidence
On CISA KEV
Not listed
Detection rule
None yet
EPSS (chance of attack)
100.1CVE-2026-110264 EPSS over time2026-102026-11-01
VEDAS (exploit evidence)
100.9CVE-2026-110264 VEDAS over time2026-102026-11-01

Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.

Who is affected

ProductAffectedNot affected
GitLab GitLabfrom 7.0 before 18.11.13
from 19.0 before 19.0.10
from 19.1 before 19.1.9
from 19.2 before 19.2.9
from 19.3 before 19.3.6
from 19.4 before 19.4.3
from 19.5 before 19.5.1
Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: gitlab gitlab, gitlab_inc. gitlab.

How to fix it

Fixed versions stated in the CVE record: 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, 19.5.1.

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

Advisories on this CVE

References

Exploits and technical analysis

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.