CVE-2025-54795: Claude Code echo command allowed bypass of user approval prompt for command execution
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Claude Code is an agentic coding tool. In versions below 1.0.20, an error in command parsing makes it possible to bypass the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. This is fixed in version 1.0.20.
Description quoted from the CVE record (assigned by GitHub_M, published 2025-08-05).
Weakness: CWE-78: Improper Neutralization of Special Elements used in an OS Command (‘OS Command Injection’)
How it can be exploited
Exploitable over the network with low attack complexity with no special attack requirements needing no privileges and a user must take an action. Impact: confidentiality high, integrity high, availability high. CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.
Public exploit evidence (Exploit Observer)
Also known as: BDU:2025-13142, CNNVD-202508-287, EUVD-2025-23573, GHSA-x56v-x2h6-7j34
Exploit Observer has no public exploit code that names this CVE or one of its aliases.
Research and write-ups (1)
- Research or write-up: https://cymulate.com/blog/cve-2025-547954-54795-claude-inverseprompt
Vulnerability databases and vendor advisories (6)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2025-23573
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-x56v-x2h6-7j34
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2025-54795
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/CVE-2025-54795
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/GHSA-x56v-x2h6-7j34
- Vulnerability database or vendor advisory: https://www.cnnvd.org.cn/home/globalSearch?keyword=CNNVD-202508-287
8 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.010
some chance of attack soon - VEDAS
- 0.514
some exploit evidence - On CISA KEV
- Not listed
- Detection rule
- None yet
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| anthropics claude-code | version < 1.0.20 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: anthropic claude_code.
How to fix it
No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
Advisories on this CVE
References
Other references
- https://github.com/anthropics/claude-code/security/advisories/GHSA-x56v-x2h6-7j34 (x_refsource_CONFIRM)
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.