CVE-2025-54135: Cursor Agent is vulnerable to prompt injection via MCP Special Files

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

Cursor is a code editor built for programming with AI. Cursor allows writing in-workspace files with no user approval in versions below 1.3.9, If the file is a dotfile, editing it requires approval but creating a new one doesn’t. Hence, if sensitive MCP files, such as the .cursor/mcp.json file don’t already exist in the workspace, an attacker can chain a indirect prompt injection vulnerability to hijack the context to write to the settings file and trigger RCE on the victim without user approval. This is fixed in version 1.3.9.

Description quoted from the CVE record (assigned by GitHub_M, published 2025-08-05).

Weakness: CWE-78: Improper Neutralization of Special Elements used in an OS Command (‘OS Command Injection’); CWE-829: Inclusion of Functionality from Untrusted Control Sphere

How it can be exploited

Exploitable over the network with high attack complexity needing low privileges and no user interaction. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.

Public exploit evidence (Exploit Observer)

Also known as: BDU:2025-09488, CNNVD-202508-284, EUVD-2025-23569

Exploit Observer links 2 pieces of public exploit code or detection modules that name this CVE or one of its aliases.

Exploit code and modules (2)

Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.

Vulnerability databases and vendor advisories (3)

Catalogue entries, not exploit evidence.

38 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.021
some chance of attack soon
VEDAS
0.515
some exploit evidence
On CISA KEV
Not listed
Detection rule
None yet

Who is affected

ProductAffectedNot affected
cursor cursorversion < 1.3.9Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: anysphere cursor, anysphere,_inc. cursor.

How to fix it

No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

Advisories on this CVE

References

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.