CVE-2025-48384: Git Link Following Vulnerability
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When reading a config value, Git strips any trailing carriage return and line feed (CRLF). When writing a config entry, values with a trailing CR are not quoted, causing the CR to be lost when the config is later read. When initializing a submodule, if the submodule path contains a trailing CR, the altered path is read resulting in the submodule being checked out to an incorrect location. If a symlink exists that points the altered path to the submodule hooks directory, and the submodule contains an executable post-checkout hook, the script may be unintentionally executed after checkout. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Description quoted from the CVE record (assigned by GitHub_M, published 2025-07-08).
Weakness: CWE-436: Interpretation Conflict; CWE-59: Improper Link Resolution Before File Access (‘Link Following’)
How it can be exploited
Exploitable over the network with high attack complexity needing low privileges and a user must take an action. Impact: confidentiality high, integrity high, availability high. CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: no. Technical impact: total.
- On CISA KEV since
- 2025-08-25
- US federal deadline
- 2025-09-15
- Ransomware use
- Not known
Public exploit evidence (Exploit Observer)
Also known as: BDU:2025-08691, CNNVD-202507-1041, EUVD-2025-20677, SNYK-ALMALINUX10-GITSUBTREE-10945176, SNYK-ALPINE322-GIT-10669395, SNYK-CENTOS7-GITGNOMEKEYRING-10669307, SNYK-DEBIAN11-GIT-10664003, SNYK-UBUNTU1604-GIT-10664193, SNYK-UBUNTU2004-GIT-10664188, SNYK-UBUNTU2404-GIT-10664185, SNYK-UNMANAGED-GITGIT-10664667
VEDAS cluster: VEDAS:ARCHANGELVOYAGER
Exploit Observer links 74 pieces of public exploit code or detection modules that name this CVE or one of its aliases.
Exploit code and modules (74)
Code that names this CVE. A repository can be a working exploit, a scanner, a fake or malware; read it before running anything.
- Code repository: https://github.com/acheong08/cve-2025-48384
- Code repository: https://github.com/admin-ping/cve-2025-48384-rce
- Code repository: https://github.com/airkewld/cve-2025-48384
- Code repository: https://github.com/airkewld/cve-2025-48384-submodule
- Code repository: https://github.com/alex0young/cve-2025-48384-1
- Code repository: https://github.com/altm4n/cve-2025-48384
- Code repository: https://github.com/altm4n/cve-2025-48384-hub
- Code repository: https://github.com/altm4n/cve-2025-48384-sub
- Code repository: https://github.com/anezatraa/cve-2025-48384-submodule
- Code repository: https://github.com/anthonyc53/cve-2025-48384
- Code repository: https://github.com/arun1033/cve-2025-48384
- Code repository: https://github.com/beishanxueyuan/cve-2025-48384
- and 62 more
Research and write-ups (3)
- Research or write-up: https://dgl.cx/2025/07/git-clone-submodule-cve-2025-48384
- Research or write-up: https://security.alpinelinux.org/vuln/CVE-2025-48384
- Research or write-up: https://www.crowdstrike.com/en-us/blog/crowdstrike-falcon-blocks-git-vulnerability-cve-2025-48384
Vulnerability databases and vendor advisories (25)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://access.redhat.com/security/cve/cve-2025-48384
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2025-20677
- Vulnerability database or vendor advisory: https://linux.oracle.com/cve/CVE-2025-48384.html
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2025-48384
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/CVE-2025-48384
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/ROOT-OS-DEBIAN-12-CVE-2025-48384
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/ROOT-OS-UBUNTU-2004-CVE-2025-48384
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/UBUNTU-CVE-2025-48384
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/UBUNTU-CVE-2025-48384
- Vulnerability database or vendor advisory: https://security-tracker.debian.org/tracker/CVE-2025-48384
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-ALMALINUX10-GITSUBTREE-10945176
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-ALPINE322-GIT-10669395
- and 13 more
293 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.044
some chance of attack soon - VEDAS
- 0.970
strong exploit evidence - On CISA KEV
- Yes, since 2025-08-25
- Detection rule
- None yet
Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish. The vertical line is the day CISA added it to its exploited list.
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| git git | version < 2.43.7 version >= 2.44.0-rc0, < 2.44.4 version >= 2.45.0-rc0, < 2.45.4 version >= 2.46.0-rc0, < 2.46.4 version >= 2.47.0-rc0, < 2.47.3 version >= 2.48.0-rc0, < 2.48.2 version >= 2.49.0-rc0, < 2.49.1 version >= 2.50.0-rc0, < 2.50.1 | Not stated |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: git-scm git, сообщество_свободного_программного_обеспечения git.
How to fix it
CISA required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Vendor guidance:
- https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9
- https://access.redhat.com/errata/RHSA-2025:13933
- https://alas.aws.amazon.com/AL2/ALAS2-2025-2941.html
- https://linux.oracle.com/errata/ELSA-2025-11534.html
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2025-48384
- https://nvd.nist.gov/vuln/detail/CVE-2025-48384
How to detect it
There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.
Advisories on this CVE
- Git submodule CR/LF arbitrary write (CVE-2025-48384) (8 Jul 2025)
References
Government sources
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-48384 (government-resource)
Other references
- https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9 (x_refsource_CONFIRM)
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html
- http://seclists.org/fulldisclosure/2025/Sep/60
- http://www.openwall.com/lists/oss-security/2025/07/08/4
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.