CVE-2024-53150: Linux Kernel Out-of-Bounds Read Vulnerability
Advisory generated from the CVE record, CISA, Exploit Observer and VEDAS: what it is, whether it is exploited, who is affected, and how to fix and detect it.
Generated by VEDAS. Scores as of 2026-11-01 19:19 UTC. Rebuilt every few hours from cve-scores, CISA KEV and vedas-signatures. How this works and its limits.
What it is
In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Fix out of bounds reads when finding clock sources The current USB-audio driver code doesn’t check bLength of each descriptor at traversing for clock descriptors. That is, when a device provides a bogus descriptor with a shorter bLength, the driver might hit out-of-bounds reads. For addressing it, this patch adds sanity checks to the validator functions for the clock descriptor traversal. When the descriptor length is shorter than expected, it’s skipped in the loop. For the clock source and clock multiplier descriptors, we can just check bLength against the sizeof() of each descriptor type. OTOH, the clock selector descriptor of UAC2 and UAC3 has an array of bNrInPins elements and two more fields at its tail, hence those have to be checked in addition to the sizeof() check.
Description quoted from the CVE record (assigned by Linux, published 2024-12-24).
Weakness: CWE-125 Out-of-bounds Read
How it can be exploited
Exploitable with local access with low attack complexity needing low privileges and no user interaction. Impact: confidentiality high, integrity none, availability high. CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
CISA assessment (SSVC): CISA assesses exploitation as active. Automatable: no. Technical impact: partial.
- On CISA KEV since
- 2025-04-09
- US federal deadline
- 2025-04-30
- Ransomware use
- Not known
Public exploit evidence (Exploit Observer)
Also known as: BDU:2025-00530, EUVD-2024-51822, GHSA-7vq8-4frp-4vcv, SNYK-CENTOS7-KERNELHEADERS-8784152, SNYK-ORACLE7-KERNELUEKDEVEL-8720761, SNYK-ORACLE9-KERNELUEKCONTAINER-8710617, SNYK-RHEL7-KERNELRTDEVEL-8550611, SNYK-RHEL7-KERNELTOOLSLIBSDEVEL-8550624, SNYK-SLES155-REISERFSKMPDEFAULT-8650904
VEDAS cluster: VEDAS:ARMOREDCLAW
Exploit Observer has no public exploit code that names this CVE or one of its aliases.
Research and write-ups (3)
- Research or write-up: https://old.rapid7.com/db/vulnerabilities/debian-cve-2024-53150
- Research or write-up: https://old.rapid7.com/db/vulnerabilities/oracle_linux-cve-2024-53150
- Research or write-up: https://www.rapid7.com/db/vulnerabilities/debian-cve-2024-53150
Vulnerability databases and vendor advisories (15)
Catalogue entries, not exploit evidence.
- Vulnerability database or vendor advisory: https://access.redhat.com/security/cve/cve-2024-53150
- Vulnerability database or vendor advisory: https://euvd.enisa.europa.eu/enisa/EUVD-2024-51822
- Vulnerability database or vendor advisory: https://github.com/advisories/GHSA-7vq8-4frp-4vcv
- Vulnerability database or vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2024-53150
- Vulnerability database or vendor advisory: https://osv.dev/vulnerability/UBUNTU-CVE-2024-53150
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-CENTOS7-KERNELHEADERS-8784152
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-ORACLE7-KERNELUEKDEVEL-8720761
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-ORACLE9-KERNELUEKCONTAINER-8710617
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-RHEL7-KERNELRTDEVEL-8550611
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-RHEL7-KERNELTOOLSLIBSDEVEL-8550624
- Vulnerability database or vendor advisory: https://security.snyk.io/vuln/SNYK-SLES155-REISERFSKMPDEFAULT-8650904
- Vulnerability database or vendor advisory: https://ubuntu.com/security/CVE-2024-53150
- and 3 more
110 more references returned by Exploit Observer did not name this CVE or an alias, so they are left out.
VEDAS data as of 2026-11-01T17:12 UTC; fetched 2026-11-02.
Live scores
- EPSS
- 0.014
some chance of attack soon - VEDAS
- 0.980
strong exploit evidence - On CISA KEV
- Yes, since 2025-04-09
- Detection rule
- Out of scope (local)
Thin horizontal line: the “likely” (EPSS 0.10) or “strong” (VEDAS 0.90) threshold. Shaded “no data” areas are periods when cve-scores did not publish.
Who is affected
| Product | Affected | Not affected |
|---|---|---|
| Linux Linux | from b8e4f1fdfa42 before a632bdcb359f (git commit) from b8e4f1fdfa42 before 45a92cbc88e4 (git commit) from b8e4f1fdfa42 before ab011f7439d9 (git commit) from b8e4f1fdfa42 before da13ade87a12 (git commit) from b8e4f1fdfa42 before 74cb86e1006c (git commit) from b8e4f1fdfa42 before ea0fa76f61cf (git commit) from b8e4f1fdfa42 before 096bb5b43edf (git commit) from b8e4f1fdfa42 before a3dd4d63eeb4 (git commit) and 4 more ranges | Not stated |
| Linux Linux | version 5.4 | 0 is not affected (up to 5.4); 5.4.287 is not affected; 5.10.231 is not affected; 5.15.174 is not affected |
Version ranges exactly as the CVE record states them. “Before X” means X is the first fixed version.
Exploit Observer also maps it to: debian debian_linux, linux linux_kernel.
How to fix it
Fixed versions stated in the CVE record: 4.20, 5.4.
CISA required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Vendor guidance:
- https://lore.kernel.org/linux-cve-announce/2024122427-CVE-2024-53150-3a7d@gregkh/
- https://source.android.com/docs/security/bulletin/2025-04-01
- https://nvd.nist.gov/vuln/detail/CVE-2024-53150
How to detect it
This bug needs local access to exploit. VEDAS signatures cover remotely exploitable bugs for now, so there is no network rule or remote check for it. Patch it and watch your endpoint telemetry for unusual local activity.
References
Government sources
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-53150 (government-resource)
Other references
- https://git.kernel.org/stable/c/a632bdcb359fd8145e86486ff8612da98e239acd
- https://git.kernel.org/stable/c/45a92cbc88e4013bfed7fd2ccab3ade45f8e896b
- https://git.kernel.org/stable/c/ab011f7439d9bbfd34fd3b9cef4b2d6d952c9bb9
- https://git.kernel.org/stable/c/da13ade87a12dd58829278bc816a61bea06a56a9
- https://git.kernel.org/stable/c/74cb86e1006c5437b1d90084d22018da30fddc77
- https://git.kernel.org/stable/c/ea0fa76f61cf8e932d1d26e6193513230816e11d
- https://git.kernel.org/stable/c/096bb5b43edf755bc4477e64004fa3a20539ec2f
- https://git.kernel.org/stable/c/a3dd4d63eeb452cfb064a13862fb376ab108f6a6
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Other databases
Where this comes from
This advisory is generated automatically by VEDAS from: CVE.org record, CISA KEV, cve-scores (EPSS and VEDAS), Exploit Observer. Text in quotes is reproduced from the source; everything else is a fixed template filled with source fields. Nothing here is written by a language model. Check the vendor advisory before acting, and read how VEDAS and Exploit Observer work, and their limits.